support: Customer Portal
Focused on delivering choice, investment protection and flexibility to organizations with valuable COBOL assets
 

Veryant Knowledge Base
Home > All Categories > isCOBOL IDE > How do I set up isCOBOL IDE on Windows to edit, compile and debug existing source code on a UNIX/Linux box?
Question Title How do I set up isCOBOL IDE on Windows to edit, compile and debug existing source code on a UNIX/Linux box?
Question:

I have an old application that is developed and maintained on an AIX system using vi editor and Micro Focus COBOL. How can I use the isCOBOL IDE on Windows for editing this source code without changing the directory structure or location?

How can I set up isCOBOL IDE to build (using the isCOBOL Compiler) and continue to be able to build the same source code with Micro Focus COBOL on the AIX box?

Answer:

Here are the steps for one way to do this:
  1. Use NFS or Samba to create a network mapped drive that will allow Windows to access the UNIX/Linux directory.
  2. In the isCOBOL IDE File menu select "Switch Workspace / Other..." to create an Eclipse workspace on that network drive
  3. In the isCOBOL IDE File menu select "New / isCOBOL Project" to create an isCOBOL Project in that workspace
  4. On the UNIX/Linux box, use the 'ln' command to create a link to the source code in the isCOBOL project's source directory.

    For example, if your existing source code is in myapp and your workspace project directory is workspace/myproject then make the link with 

    ln -s myapp workspace/myproject/source/myapp

  5. In the isCOBOL IDE Navigator right click on the source directory and select "Refresh" to see the files. If "Build Automatically" is checked in the Project menu then the IDE will automatically start compiling the source code. The .class files will be written to the output directory.

Note that the IDE will treat every file in every directory under source as COBOL source code. You can turn off "Build Automatically" and instead use "Build Working Set" to create a "COBOL Source" working set and build just that.
Authored by: Veryant Support This question has been viewed 4676 times so far.
Click Here to View all the questions in isCOBOL IDE category.
File Attachments File Attachments
There are no attachment file(s) related to this question.
How helpful was this article to you?
User Comments User Comments Add Comment
There are no user comments for this question. Be the first to post a comment. Click Here
Related Questions Related Questions
  1. How do I resolve the error: Launching has encountered a problem - An internal error occurred during: "Launching ___". com/iscobol/rts/IscobolClass?
  2. How do I resolve the error "Unhandled event loop exception"?
  3. How do I set up a CVS repository and access it from Eclipse and the isCOBOL IDE?
  4. isCOBOL IDE or Eclipse error "Workspace in use or cannot be created, choose a different one"
  5. How do I make an isCOBOL program that will run on a mobile device, like iPad?
  6. isCOBOL IDE Eclipse Troubleshooting
  7. Does Veryant provide a plugin to Eclipse or did Veryant customize Eclipse to be the IDE for isCOBOL?
  8. What are the steps to add an external tool or integrate a utility such as JDBC2FD into the isCOBOL IDE?
  9. Can you recommend a book for learning the Eclipse based isCOBOL IDE?
  10. Generate stopped working after upgrading the isCOBOL IDE
  11. How do I install support for Subversion (SVN) in Eclipse or isCOBOL IDE?
  12. What is the current working directory when I launch my program from the IDE?
  13. How do I configure the IDE to put logs and other files in separate project folders?
  14. On which version of Eclipse are the isCOBOL 's built?
  15. How do I install new plugins received from Veryant Support?
  16. Toggling comments in the properties file editor
  17. Is there a way to stop the pop up from coming up when I start to type in code in the program?
  18. Were you aware of the ability of "block selection" in the isCOBOL Editor under Eclipse?
  19. How can I work with the java property 'file.encoding' inside the isCOBOL IDE?
  20. Did you know you can compare text files using the isCOBOL IDE?
  21. Did you know how to generate and compile an isCOBOL IDE workspace in background-mode?
  22. How to filter the problems view to avoid seeing the errors of so many different programs in a project?
  23. How can we avoid to select the way a program will be executed in the IDE each time we want to test it?
  24. How to create groups of fields on the IDE screen painter, that use the same area on the screen, but visible at different moments?
Article Information Additional Information
Article Number: 66
Created: 2009-09-02 12:03 PM
Rating: 1 Star
 
Article Options Article Options
Print Question Print this Question
Email Question Email Question to Friend
Export to Adobe PDF Export to PDF File
Export to MS Word Export to MS Word
Bookmark Article
Subscribe to Article Subscribe to Article
 
Search Knowledge Base Search Knowledge Base



 
 

© Veryant - All Rights Reserved
Veryant and isCOBOL are trademarks or registered marks of Veryant in the United States and other countries. All other marks are the property of their respective owners.