What's the meaning of the error 'Software Incompatiblity'

Question ID : 306
Created on 2019-11-08 at 2:19 AM
Author : Veryant Support [support@veryant.com]

Online URL : http://support.veryant.com/support/phpkb/question.php?ID=306



When isCOBOL Client connects to an isCOBOL Server, the following error may appear:

   Software Incompatibility
   Client release (###) is incompatible with Application Server (###)
This error means that the isCOBOL Client version is different from the isCOBOL Server version and therefore it's not compatible.
The number in parenthesis identifies the isCOBOL version. table:

number
isCOBOL version
17
2011 R3
18
2012 R1
20
2012 R2
21
2013 R1
25
2013 R2
29
2014 R1
31
2015 R1
35
2016 R1
36
2016 R2
46
2017 R1
51
2017 R2
57
2018 R1
59
2018 R2
61
2019 R1
64
2019 R2

Note - the above numbers refers to the GA release of each isCOBOL version. Numbers in between those listed here refer to Alpha and Beta builds.

Ensure that isCOBOL Client and isCOBOL Server are the same version to successfully run applications.



Back to Original Question