How do I set up isCOBOL IDE on Windows to edit, compile and debug existing source code on a UNIX/Linux box?

Question ID : 66
Created on 2009-09-02 at 12:03 PM
Author : Veryant Support [support@veryant.com]

Online URL : http://support.veryant.com/support/phpkb/question.php?ID=66



Question:

I have an old application that is developed and maintained on an AIX system using vi editor and Micro Focus COBOL. How can I use the isCOBOL IDE on Windows for editing this source code without changing the directory structure or location?

How can I set up isCOBOL IDE to build (using the isCOBOL Compiler) and continue to be able to build the same source code with Micro Focus COBOL on the AIX box?

Answer:

Here are the steps for one way to do this:
  1. Use NFS or Samba to create a network mapped drive that will allow Windows to access the UNIX/Linux directory.
  2. In the isCOBOL IDE File menu select "Switch Workspace / Other..." to create an Eclipse workspace on that network drive
  3. In the isCOBOL IDE File menu select "New / isCOBOL Project" to create an isCOBOL Project in that workspace
  4. On the UNIX/Linux box, use the 'ln' command to create a link to the source code in the isCOBOL project's source directory.

    For example, if your existing source code is in myapp and your workspace project directory is workspace/myproject then make the link with 

    ln -s myapp workspace/myproject/source/myapp

  5. In the isCOBOL IDE Navigator right click on the source directory and select "Refresh" to see the files. If "Build Automatically" is checked in the Project menu then the IDE will automatically start compiling the source code. The .class files will be written to the output directory.

Note that the IDE will treat every file in every directory under source as COBOL source code. You can turn off "Build Automatically" and instead use "Build Working Set" to create a "COBOL Source" working set and build just that.


Back to Original Question