support: Customer Portal
Focused on delivering choice, investment protection and flexibility to organizations with valuable COBOL assets
 

Veryant Knowledge Base
Home > All Categories > isCOBOL IDE > How to run batch programs on a Linux server and compile and debug them from the IDE
Question Title How to run batch programs on a Linux server and compile and debug them from the IDE

For many customers, the possibility of performing most of the development and testing tasks from a central point, the isCOBOL IDE, is highly desirable, even when the object classes are to be located and run from batch scripts on a Linux server.
First, it is possible to open an SSH terminal connection to the Linux server directly from the IDE, doing the following.

First, it is possible to open an SSH terminal connection to the Linux server directly from the IDE, doing the following.

  • Show the terminal view: Window > Show view > Other > Terminal > Terminal
  • Configure the SSH settings in order to connect to the Linux Server using the [Open Terminal] Icon located near to the Terminal View
  • Select the SSH Terminal type of terminal and enter the host settings, IP address, user and password. You may leave the rest of the setting with the defaults provided. Click OK.
  • On the Linux Side enable a folder to be shared over the network. Your system administrator may help you to do that.
  • On the Windows side, where the IDE is located, create a mapped network drive pointing to the Linux shared folder. For this example, it will be the L: drive.
  • On the IDE, open the project that will perform the remote debugging and create a new output folder: File > New > Folder. And link it to a specific folder on the network drive.
  • Change the -od compiler option to point to that folder: lnxoutput Project > Properties > isCOBOL Settings > Compile/Runtime options Click [Apply and Close].
  • Create a new Debug configuration
  • Click in the New Launch Configuration button under the isCOBOL Remote Application and enter the Host IP Address of the Linux Server and the debug port (this is the same debug port that will be configured on the Linux side as explained on a later step). Click [Apply].
  • On the Linux side create a run.properties text file with the following contents:
  •    iscobol.rundebug=2
       iscobol.debug.port=10999
    
       iscobol.code_prefix=/path/to/the/remotedebug/output/classes
    
    
       iscobol.tracelevel=1
       iscobol.logfile=./linux_is_log.log
    

  • Compile the program on the IDE (that will place the output class in the lnxoutput folder, which is a folder on the Linux server, the one included in the iscobol.code_prefix property)
  • Using the terminal view run the program on the Linux server, using the script you have, which will contain a main command like the following
  •    iscrun -c run.properties MYTEST1
    
    That will show a message similar to the following:
       Using ISCOBOL=/home/esosagt/isCOBOL2020R1
       Using ISCOBOL_JRE_ROOT=/home/esosagt/jdk1.8.0_201
       Using LD_LIBRARY_PATH=/home/esosagt/isCOBOL2020R1/native/lib
       Configuration: ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), dynamically linked, BuildID[sha1]=fc0b62d72cf0d3445cce23779aacd9ab9a739369, not stripped
       Debugger listening on port 10999 ...
    

  • On the IDE start the REMOTE01 debug session (which will attach the program running on the Linux server)
  • When you finish debugging you will notice the program has successfully run on the Linux side. For the example shown here it generate a log file with the results of the multiply operations as shown in the Terminal view.
  • Authored by: Veryant Support This question has been viewed 650 times so far.
    Click Here to View all the questions in isCOBOL IDE category.
    File Attachments File Attachments
    How helpful was this article to you?
    User Comments User Comments Add Comment
    There are no user comments for this question. Be the first to post a comment. Click Here
    Related Questions Related Questions
    1. How do I resolve the error: Launching has encountered a problem - An internal error occurred during: "Launching ___". com/iscobol/rts/IscobolClass?
    2. How do I set up a CVS repository and access it from Eclipse and the isCOBOL IDE?
    3. How do I resolve the error "Unhandled event loop exception"?
    4. How to filter the problems view to avoid seeing the errors of so many different programs in a project?
    5. isCOBOL IDE or Eclipse error "Workspace in use or cannot be created, choose a different one"
    6. How do I make an isCOBOL program that will run on a mobile device, like iPad?
    7. isCOBOL IDE Eclipse Troubleshooting
    8. Does Veryant provide a plugin to Eclipse or did Veryant customize Eclipse to be the IDE for isCOBOL?
    9. Can you recommend a book for learning the Eclipse based isCOBOL IDE?
    10. What are the steps to add an external tool or integrate a utility such as JDBC2FD into the isCOBOL IDE?
    11. How do I install support for Subversion (SVN) in Eclipse or isCOBOL IDE?
    12. On which version of Eclipse are the isCOBOL 's built?
    13. Generate stopped working after upgrading the isCOBOL IDE
    14. How do I set up isCOBOL IDE on Windows to edit, compile and debug existing source code on a UNIX/Linux box?
    15. What is the current working directory when I launch my program from the IDE?
    16. How do I configure the IDE to put logs and other files in separate project folders?
    17. How do I install new plugins received from Veryant Support?
    18. Were you aware of the ability of "block selection" in the isCOBOL Editor under Eclipse?
    19. Toggling comments in the properties file editor
    20. Is there a way to stop the pop up from coming up when I start to type in code in the program?
    21. How to create groups of fields on the IDE screen painter, that use the same area on the screen, but visible at different moments?
    22. How can I work with the java property 'file.encoding' inside the isCOBOL IDE?
    23. Did you know you can compare text files using the isCOBOL IDE?
    24. Did you know how to generate and compile an isCOBOL IDE workspace in background-mode?
    25. How can we avoid to select the way a program will be executed in the IDE each time we want to test it?
    26. How to create a report with the IDE Report Designer
    27. How to use existing FD/SL copybooks in the Screen Programs without generating FD/SL from IDE Data View
    Article Information Additional Information
    Article Number: 311
    Created: 2020-05-08 3:20 AM
    Rating: No Rating
     
    Article Options Article Options
    Print Question Print this Question
    Email Question Email Question to Friend
    Export to Adobe PDF Export to PDF File
    Export to MS Word Export to MS Word
    Bookmark Article
    Subscribe to Article Subscribe to Article
     
    Search Knowledge Base Search Knowledge Base



     
     

    © Veryant - All Rights Reserved
    Veryant and isCOBOL are trademarks or registered marks of Veryant in the United States and other countries. All other marks are the property of their respective owners.